查看: 796|回复: 4

文本转换16进制问题

[复制链接]

2

主题

26

帖子

199

积分

初级会员

Rank: 2

积分
199
发表于 2014-1-24 15:25:49 | 显示全部楼层 |阅读模式
  1. 事件 按钮3.被单击()
  2. 编辑框3.内容= 到十六进制(到整数(编辑框2.内容))
  3. 结束 事件
复制代码

到十六进制 整数可以正常转换 文本一转换就出错


哪们兄弟知道如果 文本要转换成16进制度数据的时候应该怎么转换





回复

使用道具 举报

0

主题

28

帖子

252

积分

中级会员

Rank: 3Rank: 3

积分
252
发表于 2014-1-24 21:38:33 | 显示全部楼层
本帖最后由 圣士龙魂 于 2014-1-24 21:45 编辑

.版本 2
.子程序 文本到十六进制封包, 文本型
.参数 欲转换文本, 文本型
.局部变量 文本, 文本型
.局部变量 字节集, 字节集
.局部变量 长度, 整数型
.局部变量 字节数组, 字节型, , "0"
.局部变量 计次, 整数型
.局部变量 字节, 字节型
.局部变量 整数数组, 整数型, , "0"
.局部变量 文本数组, 文本型, , "0"
.局部变量 十六进制封包, 文本型
文本 = 欲转换文本
字节集 = 到字节集 (文本)
长度 = 取字节集长度 (字节集)
.计次循环首 (长度, 计次)
    字节 = 取字节集数据 (字节集, 1, 计次)
    加入成员 (字节数组, 字节)
.计次循环尾 ()
计次 = 1
.计次循环首 (长度, 计次)
    加入成员 (整数数组, 到数值 (字节数组 [计次]))
.计次循环尾 ()
计次 = 1
.计次循环首 (长度, 计次)
    .如果 (整数数组 [计次] = 0)
        加入成员 (文本数组, “00”)
    .否则
        加入成员 (文本数组, 取十六进制文本 (整数数组 [计次]))
    .如果结束
.计次循环尾 ()
计次 = 1
.计次循环首 (长度, 计次)
    .如果真 (取文本长度 (文本数组 [计次]) = 1)
        文本数组 [计次] = “0” + 文本数组 [计次]
    .如果真结束
    ' 编辑框2.加入文本 (文本数组 [计次] + “ ”)
    ' 如果真 (计次 % 16 = 0)
    ' 编辑框2.加入文本 (#换行符)
    十六进制封包 = 十六进制封包 + 到文本 (文本数组 [计次] + “ ”)
.计次循环尾 ()
返回 (十六进制封包)


回复 支持 反对

使用道具 举报

2

主题

26

帖子

199

积分

初级会员

Rank: 2

积分
199
 楼主| 发表于 2014-1-24 23:49:51 | 显示全部楼层
圣士龙魂 发表于 2014-1-24 21:38
.版本 2
.子程序 文本到十六进制封包, 文本型
.参数 欲转换文本, 文本型

这是易语言的  E4A应该怎么写  哪位大神帮转下
回复 支持 反对

使用道具 举报

3

主题

38

帖子

457

积分

中级会员

Rank: 3Rank: 3

积分
457
发表于 2014-1-26 21:24:07 | 显示全部楼层
圣士龙魂 发表于 2014-1-24 21:38
.版本 2
.子程序 文本到十六进制封包, 文本型
.参数 欲转换文本, 文本型

这哥们真逗。。
回复 支持 反对

使用道具 举报

5

主题

204

帖子

2089

积分

资深会员

Rank: 6Rank: 6

积分
2089
QQ
发表于 2016-10-12 15:42:40 | 显示全部楼层
编辑框2.内容=字节集到十六进制(文本到字节(编辑框1.内容,"GBK"))
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

扫描关注公众号,签到即可获得额外金币噢
快速回复 返回顶部 返回列表