查看: 2524|回复: 7

编译时提示JAVA版本不对,怎么办?

[复制链接]

1

主题

34

帖子

196

积分

初级会员

Rank: 2

积分
196
发表于 2014-3-5 11:09:25 | 显示全部楼层 |阅读模式
确定我安装的就是JAVA1.6,但还是提示版本错误,无法编译,应该如何解决?
回复

使用道具 举报

1

主题

8

帖子

133

积分

初级会员

Rank: 2

积分
133
发表于 2014-3-5 15:29:30 | 显示全部楼层
请看看JDK文件路径是否有空格或者中文!
回复 支持 反对

使用道具 举报

1

主题

34

帖子

196

积分

初级会员

Rank: 2

积分
196
 楼主| 发表于 2014-3-5 15:52:55 | 显示全部楼层
我是按照实例输入目录啊(C:\Program Files\Java\jdk1.6.0_10\bin)
谢谢,我换个目录试试
回复 支持 反对

使用道具 举报

1

主题

34

帖子

196

积分

初级会员

Rank: 2

积分
196
 楼主| 发表于 2014-3-5 16:17:21 | 显示全部楼层
我试了,无论怎样改变JAVA安装目录,都不行,一直提示:编译错误,请检查JAVA版本,必须是1.6。。。。
回复 支持 反对

使用道具 举报

1

主题

34

帖子

196

积分

初级会员

Rank: 2

积分
196
 楼主| 发表于 2014-3-5 16:18:59 | 显示全部楼层
请大神们帮帮我吧!
回复 支持 反对

使用道具 举报

1

主题

34

帖子

196

积分

初级会员

Rank: 2

积分
196
 楼主| 发表于 2014-3-7 16:26:22 | 显示全部楼层
到底是什么愿意呢?帮帮我吧!
回复 支持 反对

使用道具 举报

1

主题

183

帖子

2963

积分

VIP商业用户

Rank: 8Rank: 8

积分
2963
发表于 2014-3-7 20:15:34 | 显示全部楼层
我也是啊怎么办
回复 支持 反对

使用道具 举报

0

主题

15

帖子

131

积分

初级会员

Rank: 2

积分
131
发表于 2014-4-13 17:00:44 | 显示全部楼层
我的也是那种情况,没有解?路径没空格中文,调试CMD-java-javac都正常!
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

扫描关注公众号,签到即可获得额外金币噢
快速回复 返回顶部 返回列表